VRRP Monitoring of the Uplink Interface status on Huawei routers.

VRRP Monitoring of the Uplink Interface status on Huawei routers.

VRRP basic concepts.

If association between VRRP and the uplink interface is not configured and the uplink interface or link of R1(master) in the VRRP group fails, the VRRP group cannot detect the fault and the master cannot forward traffic. In this case, the active/standby switchover cannot be performed, causing a traffic blackhole.

Networking description.

An enterprise LAN has two Campus GWs . Users are connected to access switches and access switches aggregate to the GWs. DHCP server for the campus network is on the GWs. VRRP is implemented to enhance gateway reliability, multiple gateways are deployed to prevent a single point of failure. Implement VRRP monitoring of the uplink interface, when there’s a fault on the uplink interface or the link, the device reduces the VRRP priority. This ensures that the backup with a normal uplink can be elected as the master to forward packets.. This helps to minimize service interruptions and prevent traffic loss.

Step 1: Configure Basic parameters on devices.

*******************************************ACC-1
system-view
sysname ACC-1
#
vlan batch 10
#
port-group 1
 group-member Ethernet0/0/1
 group-member Ethernet0/0/2
 port link-type access
 port default vlan 10
#
port-group 2
 group-member GigabitEthernet0/0/1
 group-member GigabitEthernet0/0/2
 port link-type trunk
 undo port trunk allow-pass vlan 1
 port trunk allow-pass vlan 10
#
return

*******************************************R3
system-view
sysname R3
#
interface GigabitEthernet0/0/0
 ip address 10.0.0.2 255.255.255.252
#
interface LoopBack0
 ip address 8.8.8.8 255.255.255.255
#
ip route-static 192.168.10.0 255.255.255.0 10.0.0.1
#
return

*******************************************R4
system-view
sysname R4
#
interface GigabitEthernet0/0/0
 ip address 10.0.0.6 255.255.255.252
#
interface LoopBack0
 ip address 8.8.8.8 255.255.255.255
#
ip route-static 192.168.10.0 255.255.255.0 10.0.0.5
#
return

*******************************************R1
system-view
sysname R1
#
vlan batch 10
#
dhcp enable
#
ip pool 1
 gateway-list 192.168.10.3
 network 192.168.10.0 mask 255.255.255.0
 excluded-ip-address 192.168.10.1 192.168.10.2
#
interface Vlanif10
 ip address 192.168.10.1 255.255.255.0
 dhcp select global
#
interface GigabitEthernet0/0/0
 ip address 10.0.0.1 255.255.255.252
#
interface GigabitEthernet0/0/1
 portswitch
 port link-type trunk
 undo port trunk allow-pass vlan 1
 port trunk allow-pass vlan 10
#
ip route-static 8.8.8.8 255.255.255.255 10.0.0.2
#
return

*******************************************R2
system-view
sysname R2
#
vlan batch 10
#
dhcp enable
#
ip pool 1
 gateway-list 192.168.10.3
 network 192.168.10.0 mask 255.255.255.0
 excluded-ip-address 192.168.10.1 192.168.10.2
#
interface Vlanif10
 ip address 192.168.10.2 255.255.255.0
 dhcp select global
#
interface GigabitEthernet0/0/0
 ip address 10.0.0.5 255.255.255.252
#
interface GigabitEthernet0/0/2
 portswitch
 port link-type trunk
 undo port trunk allow-pass vlan 1
 port trunk allow-pass vlan 10
#
ip route-static 8.8.8.8 255.255.255.255 10.0.0.6
#
return

Step 2. Configure VRRP.

*******************************************R1
system-view
#
interface Vlanif10
 vrrp vrid 1 virtual-ip 192.168.10.3
 vrrp vrid 1 priority 150
 vrrp vrid 1 preempt-mode timer delay 10
#
return

*******************************************R2
system-view
#
interface Vlanif10
 vrrp vrid 1 virtual-ip 192.168.10.3
#
return

Step 3: Check VRRP status.

Step 3: Simulate traffic from PC , shutdown the uplink interface of R1 (master)

There is packet loss when the uplink interface of R1 goes down.

Step 4: Configure VRRP to monitor the status of the uplink interface.

*******************************************R1
system-view
#
interface Vlanif10
 vrrp vrid 1 track interface GigabitEthernet0/0/0 reduced 60

Step 5: Check VRRP status.

Step 6: Simulate traffic from PC , shutdown the uplink interface of R1 (master)

R1 detects a fault on the uplink interface (GigabitEthernet0/0/0), the device reduces the VRRP priority by 60, the backup which has a normal uplink has a higher priority and is now elected to be the master.



Leave a Reply

This website uses cookies and asks your personal data to enhance your browsing experience.