Implementing IS-IS Auto Fast Reroute(FRR) on Huawei Devices

Implementing IS-IS Auto Fast Reroute(FRR) on Huawei Devices

When a fault occurs on a network running IS-IS as the IGP, IS-IS must complete the following procedure before switching traffic to the backup link: Detect the fault, Update LSPs, flood LSPs, Calculate routes through SPF, and deliver the routes to the FIB. The process is lengthy and sensitive services like VOIP will be interrupted.

Deploying IS-IS Auto FRR(Fast Reroute) enables IS-IS to pre-calculate a backup path based on the LSDBs on the network and saves the backup path in the forwarding table for traffic protection in the case of a fault.

This lab demonstrates how to configure IS-IS Auto FRR on Huawei devices.

Configuration Steps

Step 1: Configure IP Addresses on interfaces on all routers as follows.

***********************R1
#
sysname R1
#
interface GigabitEthernet0/0/0
 ip address 20.20.20.0 255.255.255.254
#
interface GigabitEthernet0/0/1
 ip address 10.10.10.0 255.255.255.254
#
interface LoopBack0
 ip address 1.1.1.1 255.255.255.255
#
***********************R2
#
sysname R2
#
interface GigabitEthernet0/0/0
 ip address 20.20.20.1 255.255.255.254
#
interface GigabitEthernet0/0/1
 ip address 20.20.20.2 255.255.255.254
#
interface LoopBack0
 ip address 2.2.2.2 255.255.255.255
#
***********************R3
#
sysname R3
#
interface GigabitEthernet0/0/0
 ip address 20.20.20.3 255.255.255.254
#
interface GigabitEthernet0/0/1
 ip address 10.10.10.5 255.255.255.254
#
interface LoopBack0
 ip address 3.3.3.3 255.255.255.255
#
***********************R4
#
sysname R4
#
interface GigabitEthernet0/0/0
 ip address 10.10.10.1 255.255.255.254
#
interface GigabitEthernet0/0/1
 ip address 10.10.10.2 255.255.255.254
#
interface LoopBack0
 ip address 4.4.4.4 255.255.255.255
#
***********************R5
#
sysname R5
#
interface GigabitEthernet0/0/0
 ip address 10.10.10.3 255.255.255.254
#
interface GigabitEthernet0/0/1
 ip address 10.10.10.4 255.255.255.254
#
interface LoopBack0
 ip address 5.5.5.5 255.255.255.255
#

Step 2: Configure IS-IS on all routers and enable it on respective interfaces.

**************************R1
#
isis 20
 is-level level-2
 network-entity 49.0010.0010.0100.1001.00
 is-name R1
#
interface GigabitEthernet0/0/0
 isis enable 20
#
interface GigabitEthernet0/0/1
 isis enable 20
#
interface LoopBack0
 isis enable 20
#
**************************R2
#
isis 20
 is-level level-2
 network-entity 49.0010.0020.0200.2002.00
 is-name R2
#
interface GigabitEthernet0/0/0
 isis enable 20
#
interface GigabitEthernet0/0/1
 isis enable 20
#
interface LoopBack0
 isis enable 20
#
**************************R3
#
isis 20
 is-level level-2
 network-entity 49.0010.0030.0300.3003.00
 is-name R3
#
interface GigabitEthernet0/0/0
 isis enable 20
#
interface GigabitEthernet0/0/1
 isis enable 20
#
interface LoopBack0
 isis enable 20
#
**************************R4
#
isis 20
 is-level level-2
 network-entity 49.0010.0040.0400.4004.00
 is-name R4
#
interface GigabitEthernet0/0/0
 isis enable 20
#
interface GigabitEthernet0/0/1
 isis enable 20
#
interface LoopBack0
 isis enable 20
#
**************************R5
#
isis 20
 is-level level-2
 network-entity 49.0010.0050.0500.5005.00
 is-name R4
#
interface GigabitEthernet0/0/0
 isis enable 20
#
interface GigabitEthernet0/0/1
 isis enable 20
#
interface LoopBack0
 isis enable 20
#

Step 3: Verify IS-IS peering status and the routing table on all routers.

when we check the IS-IS routing of R3’s Loopback IP on R1, we only have one next hop based on the smallest cost as follows:

We need to enable IS-IS Auto FRR for fast switching of traffic to backup link before route convergence, which prevents traffic interuption when faults occurs in the network.

Step 4: Enable IS-IS Auto FRR on R1 as follows.

**************************R1
isis 20
 frr
  loop-free-alternate level-2
#

Step 5: Verify the routing table of R1 to confirm we have a backup to the 3.3.3.3/32 network on R3.

IS-IS generates a backup route when Auto FRR is enabled.

Thank you for reading. Please leave your comments below and subscribe to our YouTube channel for more content on networking using this link. Lyfey Technologies Channel

Related Posts



Leave a Reply

This website uses cookies and asks your personal data to enhance your browsing experience.