Implementing BGP Peer Groups on Cisco Routers

Implementing BGP Peer Groups on Cisco Routers

On a large network, one BGP router for example the RR could have many neighbors and this requires many configuration lines. Many of the configuration lines are repeated, hence time-consuming. The RR will also consume more resources when generating and sending updates to its peers.

A BGP peer group allows grouping of BGP neighbors who share the same policies into one group and the policies are applied to the group and not to individual peers. BGP peer groups simplify configuration and reduce the load on system resources during update generation.

Check out similar implementations on Huawei routers from this link: Implementation of BGP Peer Groups on Huawei Routers

Configuration Steps

Step 1: Configure interfaces on all routers.

****************************R1
enable
configure terminal
hostname R1
!
interface FastEthernet0/0
 ip address 10.10.10.0 255.255.255.254
 no shutdown
!
interface FastEthernet0/1
 ip address 10.10.10.2 255.255.255.254
 no shutdown
!
interface FastEthernet1/0
 ip address 10.10.10.4 255.255.255.254
 no shutdown
!
interface FastEthernet2/0
 ip address 10.10.10.6 255.255.255.254
 no shutdown
!
****************************R2
enable
configure terminal
hostname R2
!
interface FastEthernet0/0
 ip address 10.10.10.5 255.255.255.254
 no shutdown
!
****************************R3
enable
configure terminal
hostname R3
!
interface FastEthernet0/0
 ip address 10.10.10.3 255.255.255.254
 no shutdown
!
****************************R4
enable
configure terminal
hostname R4
!
interface FastEthernet0/0
 ip address 10.10.10.1 255.255.255.254
 no shutdown
!
****************************R5
enable
configure terminal
hostname R5
!
interface FastEthernet0/0
 ip address 10.10.10.7 255.255.255.254
 no shutdown
!

Step 2: Configure BGP on all routers.

We configure two BGP peer groups on R1. GROUP_INTERNAL for IBGP peering and GROUP_EXTERNAL for EBGP peering. R1 is the RR for AS 200, hence apply reflect client and next hop self command on the group instead of applying repeatedly on each IBGP peer.

*************************R2
!
router bgp 200
 neighbor 10.10.10.4 remote-as 200
!
*************************R3
!
router bgp 200
 neighbor 10.10.10.2 remote-as 200
!
*************************R4
!
router bgp 200
 neighbor 10.10.10.0 remote-as 200
!
*************************R5
!
router bgp 100
 neighbor 10.10.10.6 remote-as 200
!

Step 3: Verify BGP peering status

Latest Posts



Leave a Reply

This website uses cookies and asks your personal data to enhance your browsing experience.