Basic EIGRP Configuration on Cisco Routers

Basic EIGRP Configuration on Cisco Routers

This lab demonstrates how to configure EIGRP on cisco routers.

Configuration Steps:

Step 1: Configure hostnames and interface IPs on all routers as follows.

**************************R1
enable
configure terminal
interface Loopback0
 ip address 1.1.1.1 255.255.255.255
!
interface FastEthernet0/0
 ip address 20.20.20.2 255.255.255.254
 no shutdown
!
***************************R2
enable
configure terminal
hostname R2
!
interface Loopback0
 ip address 2.2.2.2 255.255.255.255
!
interface FastEthernet0/0
 ip address 20.20.20.0 255.255.255.254
 no shut
!
interface FastEthernet0/1
 ip address 20.20.20.3 255.255.255.254
 no shut
!
**************************R3
enable
configure terminal
hostname R3
!
interface Loopback0
 ip address 3.3.3.3 255.255.255.255
!
interface FastEthernet0/0
 ip address 10.10.10.2 255.255.255.254
 no shut
!
interface FastEthernet0/1
 ip address 10.10.10.0 255.255.255.254
 no shu
!
************************R4
enable
configure terminal
hostname R4
!
interface Loopback0
 ip address 4.4.4.4 255.255.255.255
!
interface FastEthernet0/0
 ip address 10.10.10.3 255.255.255.254
 no shut
!
***********************R5
enable
configure terminal
hostname R5
!
interface Loopback0
 ip address 5.5.5.5 255.255.255.255
!
interface FastEthernet0/0
 ip address 10.10.10.1 255.255.255.254
 no shut
!

Step 2: Configure EIGRP on all the routers.

**************************R1
!
router eigrp 20
 network 1.1.1.1 0.0.0.0
 network 20.20.20.2 0.0.0.1
 auto-summary
!
*************************R2
!
router eigrp 20
 network 2.2.2.2 0.0.0.0
 network 20.20.20.0 0.0.0.1
 network 20.20.20.2 0.0.0.1
 auto-summary
!
*************************R3
!
router eigrp 20
 network 20.20.20.0 0.0.0.1
 auto-summary
!
router eigrp 10
 network 3.3.3.3 0.0.0.0
 network 10.10.10.0 0.0.0.1
 network 10.10.10.2 0.0.0.1
 auto-summary
!
*************************R4
!
router eigrp 10
 network 4.4.4.4 0.0.0.0
 network 10.10.10.2 0.0.0.1
 auto-summary
!
*************************R5
!
router eigrp 10
 network 5.5.5.5 0.0.0.0
 network 10.10.10.0 0.0.0.1
 auto-summary
!

Step 3: Verify EIGRP adjacency status

R3 has 1 adjacency in AS 20 and 2 adjacencies in AS 10
R2 has 2 adjacencies with R1 and R3 in AS 20.

Step 4: Verify IP routing table on the routers.

R1 has learned EIGRP routes from AS 20 only. It doesn’t have routes from AS 10.
R4 only has routes from AS 10 but no routes from AS 20.

By default, EIGRP routers in different AS does not exchange routes. We need to redistribute routes between the two ASes.

Step 5: Redistribute routes between AS 10 and AS 20 on R3.

*****************************R3
!
router eigrp 20
 redistribute eigrp 10
!
router eigrp 10
 redistribute eigrp 20
!

Step 6. Verify routes are exchanged between AS 10 and AS 20.

It is best practice to configure route policies to control route redistribution. Only advertise routes that meet the conditions instead of advertising all routes.

R1 now has routes from AS 10.
R4 has routes from AS 20.

Thank you for reading our article, leave your comments in the comments section and request a lab of your choice. Check out our related posts from the website.

Related Posts



Leave a Reply

This website uses cookies and asks your personal data to enhance your browsing experience.