Basic BGP Route Reflection Configuration on Cisco Routers.
- March 26, 2024
- Posted by: Lyfey Technologies
- Categories: Cisco, Networking
No Comments
Configuration Steps:
Step 1: Configure hostnames and interface IPs on all the routers.
***************************************R1
enable
configure terminal
hostname R1
!
interface Loopback100
ip address 100.100.100.100 255.255.255.255
!
interface FastEthernet0/0
ip address 30.30.30.2 255.255.255.254
no shutdown
!
interface FastEthernet0/1
ip address 30.30.30.0 255.255.255.254
no shutdown
!
*************************************RR1
enable
configure terminal
hostname RR1
!
interface FastEthernet0/0
ip address 30.30.30.3 255.255.255.254
no shutdown
!
interface FastEthernet0/1
ip address 40.40.40.0 255.255.255.254
no shutdown
!
interface FastEthernet1/0
ip address 10.10.10.4 255.255.255.254
no shutdown
!
interface FastEthernet2/0
ip address 10.10.10.0 255.255.255.254
no shutdown
!
************************************RR2
enable
configure terminal
hostname RR2
!
interface FastEthernet0/0
ip address 30.30.30.1 255.255.255.254
no shutdown
!
interface FastEthernet0/1
ip address 40.40.40.1 255.255.255.254
no shutdown
!
interface FastEthernet1/0
ip address 20.20.20.4 255.255.255.254
no shutdown
!
interface FastEthernet2/0
ip address 20.20.20.0 255.255.255.254
no shutdown
!
************************************R5
enable
configure terminal
hostname R5
!
interface FastEthernet0/0
ip address 10.10.10.5 255.255.255.254
no shutdown
!
interface FastEthernet0/1
ip address 10.10.10.2 255.255.255.254
no shutdown
!
**********************************R6
enable
configure terminal
hostname R6
!
interface FastEthernet0/0
ip address 10.10.10.1 255.255.255.254
no shutdown
!
interface FastEthernet0/1
ip address 10.10.10.3 255.255.255.254
no shutdown
!
************************************R7
enable
configure terminal
hostname R7
!
interface FastEthernet0/0
ip address 20.20.20.5 255.255.255.254
no shutdown
!
*********************************R8
enable
configure terminal
hostname R8
!
interface FastEthernet0/0
ip address 20.20.20.1 255.255.255.254
no shutdown
!
Step 2: Configure BGP on all the routers. R5 and R6 are configured as clients of RR1 while R7 and R8 are configured as clients of RR2. RR1 and RR2 are two different clusters. Interface IP is used as the cluster ID.
********************************R1
router bgp 64000
neighbor 30.30.30.1 remote-as 64000
neighbor 30.30.30.3 remote-as 64000
!
address-family ipv4
neighbor 30.30.30.1 activate
neighbor 30.30.30.3 activate
network 100.100.100.100 mask 255.255.255.255
exit-address-family
!
********************************RR1
router bgp 64000
neighbor 10.10.10.1 remote-as 64000
neighbor 10.10.10.5 remote-as 64000
neighbor 30.30.30.2 remote-as 64000
neighbor 40.40.40.1 remote-as 64000
!
address-family ipv4
neighbor 10.10.10.1 activate
neighbor 10.10.10.1 route-reflector-client
neighbor 10.10.10.1 next-hop-self
neighbor 10.10.10.5 activate
neighbor 10.10.10.5 route-reflector-client
neighbor 10.10.10.5 next-hop-self
neighbor 30.30.30.2 activate
neighbor 40.40.40.1 activate
neighbor 40.40.40.1 route-reflector-client
exit-address-family
!
*********************************RR2
router bgp 64000
neighbor 20.20.20.1 remote-as 64000
neighbor 20.20.20.5 remote-as 64000
neighbor 30.30.30.0 remote-as 64000
neighbor 40.40.40.0 remote-as 64000
!
address-family ipv4
neighbor 20.20.20.1 activate
neighbor 20.20.20.1 route-reflector-client
neighbor 20.20.20.5 activate
neighbor 20.20.20.5 route-reflector-client
neighbor 30.30.30.0 activate
neighbor 40.40.40.0 activate
neighbor 40.40.40.0 route-reflector-client
exit-address-family
!
********************************R5
router bgp 64000
neighbor 10.10.10.4 remote-as 64000
!
address-family ipv4
neighbor 10.10.10.4 activate
exit-address-family
!
*******************************R6
router bgp 64000
neighbor 10.10.10.0 remote-as 64000
!
address-family ipv4
neighbor 10.10.10.0 activate
exit-address-family
!
*******************************R7
router bgp 64000
neighbor 20.20.20.4 remote-as 64000
!
address-family ipv4
neighbor 20.20.20.4 activate
exit-address-family
!
*******************************R8
router bgp 64000
bgp log-neighbor-changes
neighbor 20.20.20.0 remote-as 64000
!
address-family ipv4
neighbor 20.20.20.0 activate
no auto-summary
no synchronization
exit-address-family
!
Step 3: Confirm BGP peering status is Up on all the routers.
Step 4: Confirm the route 100.100.100.100/32 from R1 is advertised to RR1 and RR2 and reflected to their clients.
Related Posts
- VRRP Implementation on Huawei Routers.
- DHCP server, DHCP relay and DHCP snooping Implementation on Huawei.
- Dual Link HSB (Direct forwarding) Implementation on Huawei WACs.
- VRRP HSB (Direct forwarding) Implementation on Huawei WACs.
- VXLAN (intra-subnet communication) Implementation on Huawei switches.